Zum Inhalt springen
Kategorien
< Alle Themen
Drucken

Stabstahl So wird es gemacht

Eine Position eingeben (linear)

Sie benötigen eine Zeichnung mit der Darstellung eines Plattenbalkens in Draufsicht und Schnitt

Etwa so.soll das Bauteil aussehen.

Wählen Sie aus dem Stabstahl-Menü

z. B. 1 Anzahl = Länge/Abstand.

Das Eingabemenü für die Voreinstellungen öffnet sich.

Maske Bereich „Eingeben“

Stellen Sie Abstand und Stabdurchmesser ein.

Wählen Sie durch Klick auf das Bild bei „Ansicht aus“ die Biegeform aus.

Wählen Sie daneben die Stabansicht aus Z.

Maske Bereich „Eingeben“

Schalten Sie „Mitteln“ und „Oben“ ein (Häkchen sichtbar).

Geben Sie neben „oben : “ den Wert für die Betondeckung ein.

Klicken Sie auf den Schalter „Gerade verlegen Punkt 1“.

Geben Sie im Grundriss über Punkte 1 und 2 die Verlegepunkte ein.

Eingabe Verlegepunkte

Die Position wird in einer Voransicht dargestellt.

Fahren Sie mit dem Mauszeiger Kopf der Maske über den Eintrag „Form“.

Bereich „Form“

Stellen Sie im Bereich „Betondeckung 2 Punkte / Von Linie“ die Werte für den

Anteil der Betondeckung für links rechts unten und oben“ ein.

(Diese Werte beziehen sich auf den Bildschirm, nicht auf die Lage des Bauteils im Raum. Die Werte links und rechts werden von der gemessenen Länge abgezogen, wenn die gedachte Linie zwischen den gemessenen Punkten einen Winkel zwischen null und 45° hat. Hat sie zwischen 45 und 90°, werden die Werte für oben und unten abgezogen).

Bereich „Form“ unterer Teil.

Setzen Sie im Bereich „Biegeform“ ein Häkchen vor den einzustellenden Parameter.

Klicken Sie rechts von „Parameter A>>“ auf „2 Punkte“.

Geben Sie über Punkt 3 und 4 die Länge an, die den Parameter A bilden soll.

Voransicht nach Eingabe Punkt 3 und 4

Die Voransicht zeigt die neue Stablänge.

Fahren Sie mit dem Mauszeiger im Kopf der Maske über den Eintrag „Zeichnungsdaten“.

Bereich „Zeichnungsdaten“

Geben Sie bei „Drehwinkel Positionr. „90.00“ ein.

Geben Sie bei „Art der Positionsnr.“ „6“ ein.

Geben Sie bei „Art der Verteillinie“ „3“ ein.

Geben Sie bei „Art der Verbindungslinie“ „0“ ein.

Geben Sie bei „Stäbe zeichnen“ „4“ ein.

Geben Sie bei „Wieviele Stäbe zeichnen“ „2“ ein.

Bereich „Zeichnungsdaten“ unterer Teil

Wählen Sie aus dem Menü „Neue Lage“ den Eintrag „Pos.nummer“

Geben Sie einen Punkt ein, der zum Mittelpunkt des Positionskreises werden soll.

Fahren Sie mit dem Mauszeiger im Kopf der Maske über den Eintrag „Verlegung“.

So sollte Ihre Verlegung aussehen.

Bereich „Verlegung“

Setzen Sie im Bereich „Verlegung“ rechts neben dem Eintrag „Darstellungen“ ein Häkchen.

Wählen Sie in nächsten Fenster die Konfiguration der Darstellung.

Eine zweite Darstellung der Position wird am Fadenkreuz sichtbar.

Platzieren Sie diese Darstellung mit X=3, Y=-3 Einheiten (Betondeckung) zu Punkt 3.

Sie haben jetzt zwei Voransichten.

Beachten Sie, dass die erste Voransicht in einer anderen Farbe dargestellt wird. Dies ist jetzt die „inaktive“ Voransicht. Die zweite Voransicht ist die „aktive“. Änderungen aus den Bereichen „Verlegung“ und „Zeichnungsdaten“ wirken sich auf die „aktive“ Voransicht aus.

Klicken Sie auf „Drehen“.

Wählen Sie mit der Fangfunktion für Kreiszentren den Poskreis der aktiven Darstellung.

Drehen Sie die Positionsnummer durch „zeigen“ mit dem Fadenkreuz um –90°.

Klicken Sie auf „Schieben“.

Wählen Sie ein Element der Positionsnummer der aktiven Darstellung.

Schieben Sie die Positionsnummer mittig über die Schnittdarstellung.

So sollte Ihre Verlegung aussehen.

Klicken Sie auf „Schieben“.

Wählen Sie die Verteillinie der inaktiven Darstellung.

geben Sie einen Punkt für die neue Lage der Verteillinie ein.

Beachten Sie, dass die erste Voransicht jetzt zur „Aktiven“ Voransicht wird und die zweite zur „inaktiven“.

Dieser Wechsel kann beliebig oft wiederholt werden.

So sollte Ihre Verlegung aussehen.

Wählen Sie im Bereich „Verlegung“ aus dem Auswahlmenü rechts neben dem Eintrag „Stahlauszug“ den Eintrag „Auszug mit Vermaß. und komp. Anzahl“.

Eine dritte Darstellung der Position wird am Fadenkreuz sichtbar.

Platzieren Sie diese Darstellung mit X=3, Y=-100 Einheiten zu Punkt 3.

Sie haben jetzt drei Voransichten.

Beachten Sie, dass die beiden ersten Voransicht in der Farbe für „inaktiv“ erscheinen.

Die dritte Voransicht ist die „Aktive“.

Änderungen aus den Bereichen „Verlegung“ und „Zeichnungsdaten“ wirken sich auf die „aktive“ Voransicht aus.

Klicken Sie auf „Drehen“.

Wählen Sie mit der Fangfunktion für Kreiszentren den Poskreis der aktiven Darstellung.

Drehen Sie die Positionsnummer durch „zeigen“ mit dem Fadenkreuz um –90°.

Klicken Sie auf „Schieben“.

Wählen Sie ein Element der Positionsnummer der aktiven Darstellung.

Schieben Sie die Positionsnummer über den Stahlauszug.

Klicken Sie auf „Übernehmen“.

Die Darstellungen werden jetzt in den „richtigen“ Farben dargestellt und die Position in die Stahlliste übernommen.

Wenn Sie keine weitere Eingabe machen wollen, klicken Sie jetzt auf „Abbruch“.

So sollte Ihre vier Verlegung aussehen.

Sie haben soeben Ihrem Plan eine Stabstahlpositon mit drei Darstellungen zugefügt.

Alle Darstellungen haben gleichen Rang. Jede einzelne kann gelöscht werden (Ändern/ Löschen/ Eine Darstellung), ohne dass sich die Stahlliste ändert. Erst bei der Löschung der letzten Darstellung wird die Position aus der Stahlliste entfernt. Wollen Sie die komplette Position einschließlich aller drei Darstellungen löschen wählen Sie die Funktion „Ändern/ Löschen/ Position komplett“. Wählen Sie dann eine der Darstellungen an und bestätigen Sie die Auswahl. Die Position einschließlich aller Darstellungen wird gelöscht. Andere Positionen mit gleicher Positionsnummer im gleichen Plan bleiben natürlich bestehen.

Eine Position eingeben (radial)

Sie benötigen eine Zeichnung mit der Darstellung einer runden Platte Draufsicht und Schnitt.

Etwa so.soll das Bauteil aussehen.

Wählen Sie aus dem Stabstahl-Menü

z. B. 1 Anzahl = Länge/Abstand.

Das Eingabemenü für die Voreinstellungen öffnet sich.

Eingabevoreinstellungen

Stellen Sie Abstand und Stabdurchmesser ein.

Wählen Sie durch Klick auf das Bild die Biegeform aus. (Wählen Sie die Form A3).

Wählen Sie daneben die Stabansicht aus Y.

Fahren Sie mit dem Mauszeiger im Kopf der Maske über den Eintrag „Form“.

Bereich „Form“

Geben Sie die Parameter für die Biegeform über die Eingabehilfe „Wizard“ ein.

Klicken Sie auf das Schaltfeld „Wizard“.

Eingabemaske „Wizard“

Wählen Sie die Eingabemethode „Punkte“ in der Zeile „Neue Kante(n) von“.

Wählen Sie im vorbereiteten Schnitt die vier Eckpunkte, beginnend rechts oben gegen den Uhrzeigersinn.

Wenn eine geschlossene Biegeformen vorgeschlagen wird, wählen Sie in der Zeile „Kante(n) löschen“ den Eintrag „Letzte“. Setzen Sie ein Häkchen bei „Darstellung als Eingabe übernehmen“. Klicken Sie auf „Übernehmen“.

Im Schnitt wird jetzt schon die Schnittdarstellung des Eisens abgesetzt.

Fahren Sie mit dem Mauszeiger im Kopf der Maske über den Eintrag „Eingeben“.

Bereich „Eingeben“

Klicken Sie auf das Icon „0°“

Klicken Sie auf das Schaltfeld „Im Bogen : Mittelpunkt“.

Wählen Sie mit der Fangfunktion für Kreiszentren das Zentrum der Platte als Mittelpunkt der Verlegung (Punkt 1).

Geben Sie auf dem Kreis einen Punkt für den Anfangswinkel (und Radius) der Verlegung ein (Punkt 2).

Geben Sie auf dem Kreis einen Punkt für den Endwinkel der Verlegung ein (Punkt 3).

Eingabe Verlegepunkte

Die Position wird in einer Voransicht dargestellt.

Klicken Sie auf das Icon „180°“.

Die Stabrichtung wechselt.

Wechsel der Stabansicht

Fahren Sie mit dem Mauszeiger Kopf der Maske auf den Eintrag „Verlegung“.

Sie haben jetzt mehrere Voransichten.

Beachten Sie, dass die erste Voransicht in einer anderen Farbe dargestellt wird. Dies ist jetzt die „inaktive“ Voransicht. Die zweite Voransicht ist die „aktive“. Änderungen aus den Bereichen „Eingeben“ und „Zeichnungsdaten“ wirken sich auf die „aktive“ Voransicht aus.

Klicken Sie auf „Schieben“.

Wählen Sie ein Element der Positionsnummer der aktiven Darstellung.

Schieben Sie die Positionsnummer mittig über die Schnittdarstellung.

Klicken Sie auf „Schieben“.

Wählen Sie die Verteillinie der inaktiven Darstellung.

geben Sie einen Punkt für die neue Lage der Verteillinie ein.

Beachten Sie, dass die erste Voransicht jetzt zur „Aktiven“ Voransicht wird und die zweite zur „inaktiven“.

Dieser Wechsel kann beliebig oft wiederholt werden.

So sollte Ihre Verlegung aussehen.

Wählen Sie aus der Zeile „Stahlauszug“ den Eintrag „Auszug mit Vermaß. und komp. Anzahl“.

Eine dritte Darstellung der Position wird am Fadenkreuz sichtbar.

Platzieren Sie diese Darstellung X=3, Y=-100 Einheiten zum oberen Ende der Schnittdarstellung.

Sie haben jetzt drei Voransichten.

Beachten Sie, dass die beiden ersten Voransicht in der Farbe für „inaktiv“ erscheinen.

Die dritte Voransicht ist die „Aktive“.

Änderungen aus dem Menü „Eingeben“ wirken sich auf die „aktive“ Voransicht aus.

Klicken Sie auf „Schieben“.

Wählen Sie ein Element der Posnummer der aktiven Darstellung.

Schieben Sie die Posnummer über den Stahlauszug.

So sollte Ihre Verlegung aussehen

Fahren Sie mit dem Mauszeiger Kopf der Maske auf den Eintrag „Form“.

Bereich „Form“

Geben Sie neben „A“ und „C“ jeweils „45.0“ ein

Fahren Sie mit dem Mauszeiger Kopf der Maske auf den Eintrag „Verlegung“.

Wählen Sie zwei Zeilen unter der Zeile „Stahlauszug“ „Schieben“.

Schieben Sie die Stabdarstellung im Schnitt und den Stahlauszug um 29 Einheiten nach links.

Klicken Sie auf „Übernehmen“.

Die Darstellungen werden jetzt in den „richtigen“ Farben dargestellt und die Position in die Stahlliste übernommen.

Wenn Sie keine weitere Eingabe machen wollen, klicken Sie jetzt auf „Abbruch“.

So sollte Ihre Verlegung aussehen.

Sie haben eben Ihrem Plan eine Stabstahlpositon mit drei Darstellungen zugefügt.

Alle Darstellungen haben gleichen Rang. Jede einzelne kann gelöscht werden (Ändern/ 7 Löschen/ 1 Eine Darstellung), ohne dass sich die Stahlliste ändert. Erst bei der Löschung der letzten Darstellung wird die Position aus der Stahlliste entfernt. Wollen Sie die komplette Position einschließlich aller drei Darstellungen löschen wählen Sie die Funktion „Ändern/ Löschen/ Position komplett“. Wählen Sie dann eine der Darstellungen an und bestätigen Sie die Auswahl. Die Position einschließlich aller Darstellungen wird gelöscht. Andere Positionen mit gleicher Positionsnummer im gleichen Plan bleiben natürlich bestehen.

X2 (freie Form) konstruieren

  • Wählen Sie „EINGEBEN/ ANZAHL=LÄNGE/ABSTAND“.
  • Wählen Sie die X2-Form aus.
  • Geben Sie Punkt 1 und Punkt 2 der Verlegung ein.
  • Wechseln Sie in den Ordner „FORM“.
  • Wechseln Sie in den Ordner „FREIE FORM“.
  • Wählen Sie „X2 (=freie Form) konstruieren“.
Klicken Sie dicht neben die erste Bauteilkante auf die Seite,

auf der der Stab liegen soll. Der erste Schenkel wird

mit Nummer und Maß dargestellt

Klicken Sie dicht neben die zweite Bauteilkante auf die Seite,

auf welcher der Stab liegen soll. Der zweite Schenkel wird

mit Nummer und Maß dargestellt

Weiter so – Oh!- Hoppla – die letzte Kante war falsch
Na – ein Klick auf

und es kann weitergehen. Für die weitere Eingabe muss erst

auf geklickt werden.

Jetzt war’s auch noch die falsche Seite ! Aber wir haben ja

den Schalter – ein Klick darauf –

Und jetzt stimmt es wieder. Nur sollen beide Stabenden in

die andere Richtung weisen und eine andere Länge haben.

Im Feld geben Sie jetzt z.B. –50 ein,

der Schenkel wechselt Länge und Richtung.

(Manchmal muss es auch z.B. 50 sein, Sie sehen es sofort

und können korrigieren.

Im Feld geben Sie jetzt z.B. –50 ein,

der Schenkel wechselt Länge und Richtung.

(Manchmal muss es auch z.B. 50 sein, Sie sehen es sofort

und können korrigieren.

TIP: Auch, wenn es zwischendrin nicht so richtig klappt:

wählen und es mit

einem neuen Punkt an anderer Stelle neben der Linie

versuchen!

Die Biegeform ist nun fertig und Sie können diese

Eisen schräg verlegen

Bei Stabverlegungen wird der Stababstand rechtwinklig zu den Stäben und damit im Allgemeinen parallel zur Verlegerichtung gemessen. Liegt nun die Schalkante nicht parallel zur Verlegerichtung, würde der Stababstand parallel zur Schalkante und somit falsch gemessen.

Geben Sie eine solche Position wie folgt ein:

Geben Sie die Verlegepunkte 1 und 2 in Richtung

des zu messenden Stababstands ein.

Wählen Sie in der Maske Verlegung
Geben Sie an der Schalkante Punkt 1 und 2 für die

Schräge ein. (Punkt 1 nahe des Verlegepunktes 1)

ODER
Geben Sie die Verlegepunkte 1 und 2 an der

Schalkante ein.

Wählen Sie in der Maske Verlegung
Geben Sie die Verteillinienendpunkte 1 und 2 in Richtung

des zu messenden Stababstands ein.

ODER
Wählen Sie im Zeichnungsdatenmenü (Optik) unter

den Eintrag „Ja“

Geben Sie im Zeichnungsdatenmenü (Optik) unter

den Winkel der schrägen Kante ein.

Ergebnis:

Verankerungsgenerator

Einführung

Der Artifex Verankerungslängen-Generator errechnet die Verankerungs-/Übergreifungslänge von

Bewehrungsstäben nach DIN1045 (neu). Er bietet die Möglichkeit, die Stablängen am Anfang oder/und Ende zu verändern, sowie die Lage der Stäbe zu beeinflussen. Es wird vorausgesetzt, dass die bautechnische Funktion der einzelnen Einstellungen bekannt ist.

Handhabung

Verschiedene Eingabe – und Änderungsmenüs enthalten den Startschalter für dies Funktion.

Schalter zum Start des Verankerungsgenerators.

Nach Mausklick auf diesen Schalter öffnet sich die Maske zur Bearbeitung der Verankerungs-/ Übergreifungslänge.

Maske Verankerungsgenerator.

Alle Werte und Rechenvorgänge, die dem angezeigten Ergebnis zugrunde liegen, werden in der Liste im rechten Teil der Maske zur Prüfung angezeigt.

Es gibt keine bestimmte Reihenfolge der Eingabe.

Jede Änderung wird sofort nachgerechnet und im Ergebnisfeld angezeigt.

Das Ergebnis wird erst auf die aktuell bearbeitete Position übertragen, wenn Sie auf „OK“ klicken.

Die Einstellungen im einzelnen

(sollten in der Reihenfolge überprüft werden, um nichts zu vergessen).

Wählen Sie das Berechnungsverfahren der Verankerung.

Wählen Sie in den Auswahlmenü’s Beton- und Stahlgüte.

Wählen Sie die Art der Verankerung.

Wählen Sie den Verbundbereich.

Wählen Sie den Wert für Alpha a.

geben Sie die Werte für das Verhältnis As.reg / As.prov, sowie den Stahlsicherheitsbeiwert ein, wenn diese von der Vorgabe abweichen.

Wählen Sie den Stoßanteil ohne Längsversatz.

Anzeige des Stabdurchmessers der aktuell bearbeiteten Position.

Wenn Sie den Wert hier ändern, wird diese Änderung bei Übernahme der Berechnung auf die Position übertragen.

Ergebnisbereich.

  • Errechnete Länge = das errechnete Ergebnis.
    Sie können obige Eingaben in beliebiger Reihenfolge korrigieren, das Ergebnis wird hier dynamisch angezeigt.
  • Ihr Wert = Hier haben Sie die Möglichkeit, den errechneten Wert manuell zu korrigieren (z.B. aufzurunden).
  • Am Stabanfang berücksichtigen = Der errechnete Wert wird dem ersten Stabparameter zugeschlagen.
    Wenn der Parameter genau diesen Wert haben soll, müssen Sie ihn in der Parametermaske, aus der Sie diese Funktion aufgerufen haben, vorher auf 0 setzen.
  • Am Stabende berücksichtigen = Der errechnete Wert wird dem ersten Stabparameter zugeschlagen.
    Wenn der Parameter genau diesen Wert haben soll, müssen Sie ihn in der Parametermaske, aus der Sie diese Funktion aufgerufen haben, vorher auf 0 setzen.
  • Gesamtlänge Stab = Hier wird die aktuelle Stabgesamtlänge zur Information eingeblendet.

HINWEIS: Sie können beide Werte gleichzeitig einschalten.

Verschiebeoption.

Wenn Sie den Verankerungslängen-Generator einschalten, wird an der bearbeiteten Darstellung ein Pfeil eingeblendet. Hier können Sie auswählen ob und in welche Pfeilrichtung die Stäbe der Darstellung nach der Übernahme der Werte verschoben werden soll.

Übernimmt die errechneten Längen auf die bearbeitete Position und führt die Verschiebeoption aus.

Bricht die Funktion ohne Übernahme von Änderungen ab.

Öffnet die Online-Hilfe.

Kette eingeben (Vorgang)

ACHTUNG!

  • Sie sollten Erfahrung mit dem Vorgehen bei der normalen linearen Verlegung haben.
  • Dies ist eine Eingabeform für lineare Verlegungen mit rein grafischer Sonderfunktion.
  • Nach Abschluss der Verlegung kann die Kette nicht mehr über das unten beschriebene Menü verändert werden.
  • Jeder Bereich der Kette ist eine eigene Stabstahlposition und kann jederzeit nachträglich mit den normalen Änderungsfunktionen verändert werden.
  • Bei Änderung der Modelldaten wird der geänderte Bereich aus der Kette herausgelöst und erhält eine neue Positionsnummer.
  • Der Restbereich der Kette wird, soweit möglich, erhalten.

So geben Sie eine kettenweise Verlegung ein:

Wählen Sie aus dem Menüpunkt „EINGEBEN / KETTE EINGEBEN“ unter den drei Möglichkeiten
„ANZAHL = LÄNGE / ABSTAND“ = errechnet die Stabanzahl durch Division von Eingabelänge / vorgegebenen Stababstand.
„ABSTAND = LÄNGE / ANZAHL“ = errechnet den Stababstand durch Division von Eingabelänge / vorgegebene Stabanzahl.
„LÄNGE = ABSTAND * ANZAHL“ = errechnet die Verlegelänge durch Multiplikation von vorgegebenem Stababstand * vorgegebener Stabanzahl.

Das Eingabemenü erscheint.

Stellen Sie die gewünschten Modell und Zeichnungsdaten ein.

Geben Sie die Verlegepunkte für den ersten Bereich der Kette ein.

Es empfiehlt sich, mit folgenden Einstellungen zu arbeiten: Einfügepunkt 1; Eigendrehwinkel –90°; Eingabe im Uhrzeigersinn (von rechts nach links = Stäbe zeigen nach oben; von links nach rechts = Stäbe zeigen nach unten).

Erster Bereich der Kette.

Nach Eingabe der Punkte für den ersten Bereich klicken Sie im unteren Teil der Eingabemaske auf „Weiter“.

Das Menü für die Ketteneingabe erscheint

Maske Kette eingeben

Klicken Sie für jeden weiteren Kettenbereich auf „Eine Verlegung hinzufügen“, um den ersten Bereich zu kopieren.

Veränderungen / Anpassungen nehmen Sie später vor.

Klicken Sie auf „Letzte Verlegung entfernen“, wenn sie den letzten Bereich löschen wollen.

Fügen Sie so alle Bereich der Kette ein. Diese sind zunächst identisch.

3 Kettenbereiche, unverändert.

Hier wurde die Taste „eine Verlegungen zufügen“ zweimal betätigt.

So passen Sie die Kettenbereiche an:

Auswahl des Kettenbereichs.

Wählen Sie hier den Kettenbereich, den Sie ändern wollen.

Änderung des gewählten Bereichs.

Geben Sie hier Ihre Änderungen für den gewählten Bereich ein (Lichte = Abstand vom letzten Stab dieses Bereichs zum ersten Stab des nächsten Bereichs).

Zeigen von Anfang und Ende des gewählten Bereichs.

Alternativ können Sie hier die Bereiche grafisch verschieben. Beginnen Sie mit dem Ende des letzten Bereichs und arbeiten Sie sich nach vorne. Die Punkte eines Bereichs dürfen nicht innerhalb eines benachbarten Bereichs liegen.

Mit der Markierung „Text mittig…“ erreichen Sie, dass die Positionstexte mittig auf der Verteillinie platziert werden.

Schieben und drehen der Positionsnummer.

Verschieben oder drehen Sie hiermit einen beliebigen, von Ihnen angewählten Positionstext der Kette.

Sinnvollerweise ist dies die letzte Tätigkeit beider Ketteneingabe.

Fertige Kette.

So sieht die Kette nach der Bearbeitung mit oben genannten Funktionen aus.

Eingabemenü Kette.

So sieht das Eingabemenü nach den Veränderungen aus.

Die eingegebene Kette ist bisher nur eine Voransicht.

  • Übernehmen = Übernimmt die Ketteneingabe (Eintrag in Plan und Stahlliste).
  • Abbruch = Bricht die Eingabe ab. Die gesamte Verlegung wird verworfen.

Spezielle Auswahl (Maske)

Für die Änderungsfunktionen „Ändern / Biegeform und Parameter“ und „Ändern / Abstand/Du/Anzahl/Haken“ steht die Funktionsmaske „spezielle Auswahl“ zur Verfügung. Die Maske erlaubt Ihnen, zusätzlich zur angewählten Position weitere Positionen nach verschiedenen Kriterien für die geplante Änderungsfunktion auszuwählen.

Maske „spezielle Auswahl“

Vorgehen:

  • Die Liste oben links = zeigt alle in der Zeichnung vorhandenen Positionen auf.
  • Der stilisierte Bleistift und das Wort „Angewählte“ = zeigen die Position, welche Sie ursprünglich angewählt haben.
  • Ein grüner Haken und das Wort „Ja“ = markiert weitere angewählte Positionen.
  • Ein rotes Kreuz und das Wort „Nein“ = markiert nicht gewählte Positionen.
  • Die Taste „Schließen“ = Klicken Sie nach Beendigung Ihrer Auswahl auf diese Taste. Das Programm zeigt die vorhergehende Maske wieder an und übernimmt die danach vorgenommenen Änderungen auf alle hier selektierten Positionen.

Auswahlmöglichkeiten (Selektion):

  • Mehrere Positionen auswählen = Über die 4 Schaltfelder rechts oben wählen Sie durch einen Mausklick auf das jeweilige Schaltfeld alle Positionen, die den jeweiligen Kriterien entsprechen.
  • Alle Auswahlen auf „nicht gewählt“ setzen = Haben Sie sich verwählt, können Sie die gesamte Auswahl durch das Schaltfeld „Alle auf nicht gewählt setzen“ löschen.
  • „Sperren der Posnummer auflösen ?“ = Die Vorgabe ist „Ja“ (Häkchen an). Diese Auswahl ist erforderlich, wenn durch die Änderung an der Position eine Änderung der Positionsnummer nötig wird und Sie vorher Positionsnummern gesperrt haben.
  • Einzelne Positionen an- und abwählen = Markieren Sie die gewünschte Position in der Liste und klicken Sie in das Schaltfeld vor „Selektierte Position auswählen“. War die Position gewählt (Ja), wird sie abgewählt (Nein) und umgekehrt.
  • Einzelne Positionen prüfen = Wenn Sie bei einzelnen Positionen unsicher sind, ob sie verändert werden sollen, können Sie sich die Position im Plan anzeigen lassen. Markieren Sie die gewünschte Position in der Liste und klicken Sie auf das Schaltfeld „Zoom auf selektierte Position“. Sie können diesen Vorgang beliebig oft wiederholen.

Auswahldialog – Handhabung

Vorbemerkung zum Auswahldialog

Dieser Dialog wird für verschiedene Funktionen des Bewehrungsprogramms eingesetzt.
Hier ist die generelle Handhabung erläutert. Um die Auswahl einer Option durchzuführen und den Dialog zu schließen, klicken Sie auf eines der gezeigten Bilder.

Beispiel eines Auswahldialogs.

Menü des Auswahldialogs

Menü Auswahldialog „OK“

    Übernimmt Einstellungen und schließt den Dialog.

Menü Auswahldialog „Abbruch“

Über den Menüpunkt „Abbruch“ verlassen Sie den Dialog ohne die Einstellungen zu ändern.

Menü Auswahldialog „Bearbeiten“

Über den Menüpunkt „Bearbeiten“ Können Sie den Inhalt des Dialogs verändern.

Änderungen werden über das Schaltfeld „Ende+Daten Speichern“ übernommen oder über das Schaltfeld „Abbruch“ verworfen.

Pflege des Bildmenüs

Im oberen Teil werden alle eingestellten Auswahlen mit Ihren Daten dargestellt.

Führt zur Eingabemaske zum Erstellen einer neuen Auswahloption. Weiteres unter „Erstellen / Ändern eines Bildes im Auswahlmenü“ weiter unten.

Führt zur Eingabemaske zum Ändern einer bestehenden Auswahloption. Weiteres unter „Erstellen / Ändern eines Bildes im Auswahlmenü“ weiter unten.

Löscht die in der Liste markierte Auswahloption.

Zeigt das zur aktuellen Auswahloption zugeordnete Bild an.


Verschiebt die in der Liste markierte Auswahloption nach oben bzw. unten.

Speichert die eingegebenen Daten und schließt das Fenster „Pflege des Bildmenüs“.

Bricht die Eingabe / Änderung ab und schließt das Fenster „Pflege des Bildmenüs“.

Erstellen / Ändern eines Bildes im Auswahlmenü

Eingabe neue Option

In dieser Maske können Sie eine neue Auswahloption erstellen.

Bildauswahlpfad
Angabe des Pfades, in dem die Maske die zugehörigen Bilder sucht.

Bildauswahl

Geben Sie die Nummer des Bildes ein, welches zur Auswahloption dargestellt werden soll oder Klicken Sie auf das Schaltfeld rechts, um einen Browser zu öffnen. Das Bild muss vorher erstellt werden.
Bietet die Möglichkeit, ein Bild mittels eines Screenclips zu erzeugen.

Öffnet Microsoft Paint zur Bearbeitung des Bildes.

Dateneingabe

Geben Sie hier die Funktionsdaten ein, die nach Anwahl des Bildes im Auswahlmenü durchgeführt werden sollen.
Anleitungen hierzu können Sie aus den mitgelieferten Bildern ersehen.

Kommentarfeld

Hier können Sie einen Kommentar zum Bild eingeben. Er kann hilfreich sein für das Editieren des Menüs.

Übernimmt die Eingaben und schließt das Menü.

Verwirft die Eingaben und schließt das Menü

Menü Auswahldialog „Einstellungen“

Über den Menüpunkt „Einstellungen“ steuern Sie die Eigenschaften des Dialogs.

Größe des Dialogs: Verändern Sie die Größe des Dialogfensters (Windows Standardfunktionen). Die zuletzt gewählte Größe wird gespeichert.

hier stellen Sie ein, wo der Dialog standardmäßig erscheinen soll.

  • „als Popup an Mausposition“ – Der Dialog erscheint mit der linken oberen Ecke an der Mausposition.
  • „Letzte Position bei Verlassen“ – Der Dialog erscheint dort, wo er zuletzt verlassen wurde.
  • „Bildschirmmitte“ – Der Dialog erscheint immer in Bildschirmmitte.

    Wählen Sie die Transparenz des Dialogs über den Schieberegler (WIN XP, VISTA).

    Wählen Sie die Größe der Bilder über den Schieberegler.

    Wählen Sie die Farbe des Dialoghintergrundes.

    Wählen Sie die Farbe des Dialoghintergrundes.

    Setzt alle Einstellungen des Dialogs auf Defaultwerte zurück.


    Beendet die Einstellungen und kehrt zum Dialog zurück.

    Menü Auswahldialog „Anzeige“

Hier werden Informationen zur Auswahl angezeigt, wenn Sie mit dem Mauszeiger über eines der Bilder fahren ohne zu klicken.

Eigene Darstellungen von Positionstexten

Im Verzeichnis „…\(ARTIFEX)\DEFAULTS\SBWPOS“ finden Sie Textdateien deren Dateinamen aus einer 4-Stelligen Nummer mit der Endung „TXT“ besteht, z.B. „5603.TXT“. Diese Dateien beschreiben selbstdefinierte Positionstexte. Sie können diese Dateien mit einem Texteditor (Notepad/ Word) ändern oder durch neue Ergänzen. Für die Dateinamen können Sie die Nummern 5600 bis 5699 verwenden, die Endung muss immer „.TXT“ sein. Positionstexte können maximal zwei Zeilen umfassen. Sie können alle oben angegebenen Nummern verwenden, unabhängig davon, ob der Text 1- oder 2-zeilig ist.

Folgende Variablen stehen Ihnen für die Erstellung von Texten zur Verfügung:

$AB\.1#    fügt den Stababstand ein (mit Formatierung für eine Nachkommastelle „\.1“)

$AN#    fügt die Stabanzahl ein

$ANPB#    schreibt zur Anzahl noch die Multiklikatoren (Bauteilanzahl / Positionsanzahl), wenn diese >1

$ABT#    fügt den jeweils voreingestellten Abstandstext ein (anstelle $AN#$DZ#$DU#e=$AB\.0# = $AN#$DZ#$DU#$ABT#$AB\.0#)

$BA#    fügt die Bauteilanzahl (Multiplikator) ein

$BL#    fügt die Nummer der Bewehrungslage ein

$DT#    Fügt den Text aus dem Feld „Zusatztext“ des Untermenüs „Ansicht aus“ im Zeichnungsdatenmenü ein (z.B. für zusätzliche Angaben wie „örtlich Einpassen“).

$DU#    fügt den Stabdurchmesser ein

$DZ#    fügt das Durchmesserzeichen (Windows=248) ein

$FO#    fügt die Bezeichnung der Biegeform ein

$GESAN#    fügt die Summe aller Stückzahlen der gleichen Positionsnummer des Plans ein

$KAN#    fügt die Anzahl aller Eisen einer Kettenverlegung ein

$KET#    Text für Kettenverlegung (zweiter Text bei Kettenzusammenfassung)

$LE#    fügt die Stabgesamtlänge ein, bei von-bis Eisen den von-bis Wert

$MT#    Fügt den Text aus dem Feld „Text“ des Modelldatenmenüs ein (z.B. für zusätzliche technische Angaben wie „Schraubanschluss“).

$NOPO#    Positionskreis und –nummer werden nicht gezeichnet (z.B. für Kettenbereiche)

$PA#    fügt die Positionsanzahl (Multiplikator) ein

$PO#    fügt die Positionsnummer ein

$POSSUM#    fügt eine Addition aller Stückzahlen der gleichen Positionsnummer des Plans ein

$XLGES#    fügt die Positionslänge einer X-Eisen Position ein

$ZZ#    erlaubt zweizeiligen Text

$ZZTM#    erlaubt zweizeiligen Text, Text mittig

Durch Leerzeichen (dargestellt durch _ ) und Text zwischen den Variablen können Sie den Positionstext ergänzen.

BEISPIEL (Leerzeichen + Text):    $AN# $DZ# $DU# e= $AB\.1# cm

ERGIBT:    35 Ø 12 e= 15.0 cm

BEISPIEL: (keine Leerzeichen):   $AN#$DZ#$DU#e=$AB\.1#cm

ERGIBT:    35Ø12e=15.0cm

Um die Anzahl der Nachkommastellen für den Stababstand und die Stabgesamtlänge zu formatieren geben Sie hinter der Variable \.x ein. x steht für die Anzahl der Nachkommastellen.

BEISPIEL 1:    $AN# $DZ# $DU# e= $AB\.0# cm

ERGIBT:    35 Ø 12 e= 15 cm

BEISPIEL 2:    $AN# $DZ# $DU# e= $AB\.2# cm ( $LE\.2# m )

ERGIBT:    35 Ø 12 e= 15.50 cm ( 3,25 m )

Um eine zweite Zeile zu verwenden geben Sie am Ende der ersten Zeile $ZZ# und am Beginn der zweiten Zeile # ein. Eine dritte Zeile ist nicht möglich.
($ZZTM# anstatt $ZZ# formatiert den Text mittig)

BEISPIEL:    $AN# $DZ# $DU#$ZZ#
# e= $AB\.2# cm

ERGIBT:    35 Ø 12
e= 15.50 cm

BEISPIEL:    Verwendung fast aller Variablen

POS $PO# = $PA# x $AN# $DZ# $DU# l= $LE\.2# m$ZZ#
#$AB\.1# cm $BL#.Lage von unten

ERGIBT:    POS 16 = 6 x 35 Ø 12 l= 3.25 m
e= 15.5 cm 1. Lage von unten

BEISPIEL:    Text für erste Position einer Kette

$PA# x $KAN# $DZ# $DU#_$ZZ#
$PA# x $AN# / $AB#\.1# $KET#

ERGIBT:    1×20 Ø 12 (Text am Positionskreis)

1×10 / 15.5 (Text am Einfügepunkt des ersten Stabes)

WICHTIG !

Nach der letzten Zeile MUSS eine Leerzeile eingefügt werden.

An dieser erkennt das Programm das Ende der Datei.

Ohne diese Leerzeile wird der selbstdefinierte Text nicht funktionieren.

Einfügen von selbstdefinierten Positionstexten in die Zeichnung:

Wählen Sie im Zeichnungsdatenmenü unter „Art der Positionsnummer“ aus dem Listenfeld rechts den Eintrag „Eigene Darstellungen“. Das Programm öffnet ein Dateiauswahlfenster, aus dem Sie die gewünschte Definitionsdatei auswählen können oder geben Sie links die Nummer (Dateinamen ohne Endung) z.B. 5603 ein.

Es ist auch möglich, im Auswahlfeld des Zeichnungsdatenmenüs für die Positionstexte ausschließlich gewünschte und/oder selbstdefinierte Texte erscheinen zu lassen. Hierfür editieren Sie die mitgelieferte Datei „…\artifex\Defaults\SbwPos\POS_DIA.TX_“ und benennen Sie diese in „POS_DIA.TXT“ um. In den Kopfzeilen der Datei ist das Vorgehen erläutert.

mm – Ausgabe der Parameter und Stababstände

Standardmäßig werden die Längenangaben (Parameter) der Biegeformen in der Stahlliste und bei den vermaßten Stahlauszügen in cm ausgegeben. Gleiches gilt für die Angabe der Stababstände.

Diese Standardeinstellung kann für eine Ausgabe dieser Maße in mm wie folgt verändert werden :

1. Schließen Sie das Zeichenprogramm.

2. Im Ordner <Laufwerk>\Artifex\Defaults finden sie eine Datei mit dem Namen „sbw_mm.tx_“.

3. Kopieren Sie diese Datei in das gleiche Verzeichnis und ändern sie den Dateinamen zu „sbw_mm.txt„.

4. Nach dem Start des Bewehrungsprogramms werden alle oben genannten Maßangaben in mm dargestellt.

Wiederherstellung des Normalstandards (Maße in cm) :

1. Schließen Sie das Zeichenprogramm.

2. Im Ordner <Laufwerk>\Artifex\Defaults finden sie eine Datei mit dem Namen „sbw_mm.txt“.

3. Löschen Sie diese Datei.

4. Nach dem Start des Bewehrungsprogramms werden alle oben genannten Maßangaben in cm dargestellt.

Anzeige des Durchmesserzeichens im Positionstext

Abhängig von der Verwendeten Schriftart und des verwendeten CAD-Basisprogramms kann es vorkommen, dass das Durchmesserzeichen nicht richtig dargestellt wird.
Sie können, wie folgt die Einstellung ändern :

1. Schließen Sie das Zeichenprogramm.

2. Öffnen Sie mit dem Hilfsprogramm „Artifex-Einstellungen“ die Voreinstellungesdatei (z. B. …\Artifex\Defaults\Stab_Bew.v00) – alternativ kann diese Datei mit jedem Texteditor bearbeitet werden.

3. Gehen Sie zu Zeile 10 mit folgendem Inhalt: (??? Steht für die in der Datei bestehende Zahl)
??? ASCII-Nummer Durchmesserzeichen Dos = 237 Windows = 248
4. Ändern Sie die Zahl am Anfang der Zeile in 237 für DOS-Schriftarten (in der Regel für MicroStation) bzw. in 248 für Windows-Schriftarten (in der Regel für AutoCAD).

5. Speichern Sie die Änderung.

6. Starten Sie das CAD-Programm und das Bewehrungsprogramm.

7. Die Durchmesserzeichen werden jetzt richtig dargestellt.

Winkelangabe und Winkelzeichen für X2-Formen

Sollen vermasste X2-Eisen an den Biegestellen mit Winkelangaben versehen werden, können Sie wie folgt die Farbe der Winkelbemaßung und das ASCII-Zeichen für das Winkelzeichen einstellen :

1. Schließen Sie das Zeichenprogramm.

2. Im Ordner <Laufwerk>\Artifex\Defaults finden sie eine Datei mit dem Namen „stabdefs.txt“.

3. Bearbeiten Sie diese Datei mit einem Texteditor.

4. An erster Stelle geben Sie die Farbnummer für die Winkelbemaßung, an zweiter die ASCII-Nummer für das Winkelzeichen ein.

4. Nach dem Start des Bewehrungsprogramms werden alle Winkelangaben der Eisen mit diesen Einstellungen geschrieben.

Inhalt der Datei „stabdefs.txt“

STAB_BEW Weitere Einstellungen

3 94 //Farbe X2-Winkelbemassung und ASCII Nr Winkelzeichen

..

Buchstaben oder Zahlen an den Bewehrungseisen

Bei -X- Eisen kann jedes Eisen mit einer Bezeichnungen (Index) versehen werden. Dies kann manuell oder automatisch geschehen. Haben Sie in einer normalen Verlegung einzelne Eisen verschoben, wird diese zu einer -X- Eisen Darstellung. Hier ändert sich zunächst nichts automatisch an den zeichnerischen Einstellungen. Diese Änderungen können Sie in der Maske Polygonzug -X- Eisen + E3 Form des Zeichnungsdatenmenüs vornehmen.

Wenn Sie diese Darstellung kopieren, werden die Indizes automatisch eingeblendet, um auf die Sonderform der Darstellung hinzuweisen.

Ausgabe einer Zeichnung ohne ARX-Objekte

Über die Funktion „Plotten ohne Objekte“ aus den Menü „Hilfe“ können Sie eine AutoCAD-Zeichnung ohne ARX-Objekte zur Weitergabe an Dritte ausgeben.

In dieser Zeichnung können die Bewehrungsobjekte von Dritten verändert werden, die nicht über das Artifex-Program verfügen oder deren CAD-Basisprogramm Probleme beim Öffnen von Zeichnungen mit ARX-Objekten hat.

So gehen Sie vor:

  • Speichern Sie Ihre Zeichnung bei geladenem Artifex-Stabstahlprogramm.
  • Verwenden Sie den Befehl „Speichern als“ des CAD-Basisprogramms und speichern Sie die Zeichnung in ein anderes Verzeichnis ihrer Wahl (Transferverzeichnis).
  • Verwenden Sie die Funktion „Plotten ohne Objekte“ aus den Menü „Hilfe“.
  • Die ARX-Objekte sind jetzt aufgelöst. Dies werden Sie optisch in der Regel nicht bemerken.
  • Verlassen Sie den Zeichnungseditor.
  • Löschen Sie die Stabstahldatenbank (*.st2) im Transferverzeichnis.

ACHTUNG !

  • Alle Änderungen an den Bewehrungselementen der so weitergegebenen Zeichnung spiegeln sich nicht mehr in der Stabstahl-Datenbank (*.st2) wieder.
  • Die geänderte Zeichnung kann später nicht mehr mit dem Artifex-Bewehrungsprogramm bearbeitet werden.
  • Beim Start des Programms würden alle Elemente, die mit dem Bewehrungsprogramm erzeugt wurden, gelöscht werden.
  • Da alle ARX-Objekte in einzelne Basiselemente zerlegt werden, gibt es für den „Fremdbearbeiter“ keine automatische Stahlliste oder irgendwelche logischen Zusammenhänge zwischen den einzelnen Stabstahldarstellungen.
  • Änderungen an den Stabstahlelementen der Ausgabezeichnung durch Dritte können nicht automatisch in die Stabstahl-Datenbank (*.st2) übernommen werden.
  • Weitere Bearbeitungen führen Sie an der Ursprungszeichnung durch.

X-Bereich Ändern

In X-Bereichen können einzelne Stäbe entfernt oder zugefügt werden. Ebenso ist es möglich die Länge einzelner Stäbe zu ändern. Hierzu muss die Darstellung angewählt werden, in welcher der X-Bereich ursprünglich erstellt wurde. Wählen Sie aus dem Menü „Ändern“ die Funktion „Abstand/DU/Anzahl/Haken“ oder „Position gesamt ändern“. Das Modelldatenmenü zeigt jetzt an der Stelle, an der sonst die Stabanzahl angezeigt und bearbeitet wird, einen neuen Schalter.

Nach Klick auf den Schalter öffnet sich die Maske „-X- Eisen: Zufuegen,Loeschen…“. Hier können Sie Ihre Änderungen Vornehmen.

Alternativ können Sie die Maske sofort über die Funktion „Ändern> Weitere Änderungen> -X- Eisen: Zufügen, Löschen…“ öffnen. Wählen Sie hierfür ebenfalls die Darstellung, in welcher der X-Bereich ursprünglich erstellt wurde.

Die Änderungsoptionen sind im Abschnitt „Weitere Änderungen – -X- Eisen: Zufügen, Löschen“ erläutert.

Verwalten der Positionsnummern (Bauabschnitt)

Allgemeines

Die Positionsnummern werden in der Reihenfolge der Eingabe vergeben. Hat eine Position den gleichen Durchmesser, Biegeform, Haken, Parameter und Stahlsorte wie eine bestehende Position, wird die gleiche Positionsnummer vergeben. Wenn eine Position das Attribut „Laufende Meter“ hat, wird nur Durchmesser und Stahlsorte mit bestehenden Positionen verglichen. Alle lfdm-Positionen mit gleicher Stahlsorte und Durchmesser erhalten die gleiche Positionsnummer.

Eine Sortierung der Positionsnummern im Plan nach „von links oben nach rechts unten“ ist nicht möglich. Es können jedoch für bestimmte Bauteilbereiche Vorgaben zur Vergabe der Positionsnummern gemacht werden. Dies geschieht über Steuerdateien. Lesen Sie dazu die nachfolgenden Artikel.

Getrennt nach Bauabschnitt – nach Vorgabe

Ort und Name der Vorgabe – Steuerdatei ist: …\Artifex \Defaults\Sbwbtpos.txt.

Sie kann mit einem Texteditor (Notepad) verändert werden. Nach der Änderung mit einem Texteditor muss die Zeichnung neu geladen werden, um die Änderungen zu übernehmen.

Aufbau der Datei:

4 Anzahl der Bauabschnitte

-1 99

-2 199

-3 299

-4 399

In der ersten Zeile wird die folgende Anzahl der Bauteile eingetragen. Ist die eingegebene Anzahl größer als die Zahl der folgenden Zeilen, werden in der Auswahlliste des Programms entsprechend viele Bauteile mit der Nummer 0 angezeigt. Ist sie kleiner, werden die letzten Bauteile nicht angezeigt.

Zeilenweise werden die Nummernbereiche für die Bauteile festgelegt. Die erste Zahl ist die Nummer des Bereiches, es folgt mindestens ein Leerzeichen, die zweite Zahl ist die erste Positionsnummer (+1), welche in diesem Bereich vergeben wird.

Der Eintrag „–1 99“ legt fest, dass die erste Verlegung im Bereich –1 die Positionsnummer 100 erhält. Die Nummern für die Bereiche können beliebige positive oder negative Ganzzahlen sein.

Getrennt nach Bauabschnitt – Planbezogen

Ist keine planbezogene Steuerdatei vorhanden, wird die Datei …\Artifex \Defaults\Sbwbtpos.txt verwendet.

Erstellen einer planbezogenen Steuerdatei:

Über den untersten Eintrag der Bauabschnitt – Auswahlliste im Modelldatenmenü und das daraufhin erscheinende Menü können neue Abschnitte definiert werden. Bei der ersten Verwendung dieser Ergänzungsfunktion wird eine planbezogene Steuerdatei erstellt. Diese Datei wird in dem Verzeichnis erstellt, in dem sich Ihre aktuelle Zeichnung befindet und hat den Namen der aktuellen Zeichnung mit der Endung .BTP

Beispiel: Zeichnung 1.dwg(dgn/hmf) und Zeichnung 1.BTP.

Diese Datei enthält zunächst die Abschnitte der Vorgabe – Steuerdatei und nach Ihrer Änderung die planbezogenen Bauabschnitte. Alternativ kann die Datei mit einem Texteditor (Notepad) erstellt und verändert werden. Nach der Änderung mit einem Texteditor muss die Zeichnung neu geladen werden, um die Änderungen zu übernehmen.

Bitte beachten Sie, dass nach dem Löschen dieser Datei die planbezogene Bauabschnitts – Nummerierung nicht mehr funktioniert! Sie können aber eine neue Datei gleichen Inhalts erstellen und die Zeichnung und das Bewehrungsprogramm danach neu aufrufen.

Der Aufbau der Datei ist der gleiche wie der Aufbau der Vorgabe – Steuerdatei.

Verwendung unterschiedlicher Layer (Ebenen)

Die Darstellungen der Stabstahlpositionen werden vorgabemäßig auf dem Layer / Ebene „Stab_Bew“ gezeichnet. Es ist jedoch möglich, jede Positionsdarstellung auf benutzerdefinierte Layer / Ebenen zeichnen zu lassen. Im Modelldatenmenü kann über die Einstellung LV (LeVel=Layer/Ebene) ein zu verwendender Layer/Ebene ausgewählt werden. Dies geschieht über Steuerdateien. Lesen Sie dazu die nachfolgenden Artikel.

Eigene Layer für Stabdarstellung – nach Vorgabe

ACHTUNG: Diese Layer / Ebenensteuerdatei wird von allen artifex-Modulen verwendet !

Artifex empfiehlt bei Verwendung mehrerer Module (Stabstahl, Matten, Gebäudeentwurf…) für jedes Modul entsprechende Layer anzulegen.

Ort und Name der Vorgabe – Steuerdatei ist: …\Artifex \Defaults\ACAD.lay.

Über den untersten Eintrag der Layer – Auswahlliste im Modelldatenmenü und das daraufhin erscheinende Menü können neue Layer definiert werden. Diese stehen sofort zur Verfügung. Alternativ kann die Datei mit einem Texteditor (Notepad) verändert werden. Nach der Änderung mit einem Texteditor muss die Zeichnung neu geladen werden, um die Änderungen zu übernehmen.

Aufbau der Datei:

10 Kellergeschoss

20 Erdgeschoss

30 Obergeschoss

210 AUSSPARRUNGEN

500 OBERE_LAGE

505 UNTERE_LAGE

In der ersten Spalte wird eine beliebige Ordnungszahl eingegeben. In der zweiten Zeile der gewünschte Name für den Layer / Ebene. Der Layer / Ebene wird vom Programm in der aktuellen Zeichnung angelegt und die Stabdarstellungen darauf gezeichnet.

Für Nutzer von MicroStation <V8: Hier ist die Nummer in der ersten Spalte die Nummer der verwendeten Ebene, der Name wird ignoriert. Achten Sie darauf, die max. Anzahl der Ebenen nicht zu überschreiten.

Eigene Layer für Stabdarstellung – Projektbezogen

Artifex sucht die projektbezogene Steuerdatei ACAD.lay zuerst in dem Verzeichnis, in dem sich die Zeichnungen des aktuellen Projekts befinden.

Ist keine projektbezogene Steuerdatei vorhanden, wird die Datei …\Artifex \Defaults\ACAD.lay verwendet.

Erstellen einer planbezogenen Steuerdatei:

Kopieren Sie die Steuerdatei ACAD.lay aus dem Default-Verzeichnis in das Verzeichnis, in dem sich die Zeichnungen des aktuellen Projekts befinden. Benennen Sie die Datei NICHT um.

ACHTUNG: Diese Layer / Ebenensteuerdatei wird von allen artifex-Modulen verwendet !

Über den untersten Eintrag der Layer – Auswahlliste im Modelldatenmenü und das daraufhin erscheinende Menü können neue Layer definiert werden. Diese stehen sofort zur Verfügung. Alternativ kann die Datei mit einem Texteditor (Notepad) verändert werden. Nach der Änderung mit einem Texteditor muss die Zeichnung neu geladen werden, um die Änderungen zu übernehmen.

Einstellen der Farbe und Texthöhe für die Indizes an X-Eisen

Die Farbe für die Indizes der X-Eisen (X-Bereich, Von-Bis usw.) stellen Sie in den Voreinstellungsdateien ein.

In Zeile 34 :

2 7 Pen fuer Rahmen Biegeliste 0=Kein Rahmen Pen fuer Texte

Die zweite Ziffer (hier „7“) ist in die Farbnummer für die Texte der Rechteck- und Poskreis – Stahlliste und die Farbnummer für die Indizes.

Die Texthöhe stellen Sie ebenfalls in den Voreinstellungsdateien ein.

In Zeile 21:

12.5 Texthoehe vermasste Grundform-> Zahlen

Die Texthöhe wird für die Zahlen an den vermassten Stahlauszügen und als Texthöhe für die Indizes verwendet. Sie ist Maßstabsabhängig mit folgendem Umrechnungsfaktor:

Gewünschte Schrifthöhe im Ausdruck * Druckmaßstab / 10. Im Beispiel oben: 2.5 * 50 / 10 = 12.5 (Gewünschte Schrifthöhe im Ausdruck = 2.5mm; Druckmaßstab = 1:50). Die unterschiedlichen Eingabeeinheiten (m, cm, mm) berücksichtigt das Programm automatisch.

Eigene Layouts für Excel Stahlliste

Die Excel – Stahlliste kann neben der Vorgabegestaltung auch firmen- oder projektspezifisch gestaltet werden.

Der Vorteil der eigenen Makros und Vorlagen ist: Sie werden beim Update nicht mehr überschrieben.

Excel – Liste – nach Vorgabe

Wenn Sie im Menü für die Stahllisten auf das Schaltfeld klicken, wird das Macro „….artifex\Data\SBW\LST\wcoexcel.wps“ gestartet. Dieses Makro erstellt eine Text-Stahlliste unter Verwendung der Excel-Vorlagedatei „…\artifex\Defaults\stab_bew.xls“. Die Vorlagedatei verwendet für den Listenkopf einen fixen Bereich, welcher auf jedem Blatt des Ausdrucks erscheint. Die Vorlage enthält im Kopf ein Standardbild, welches Sie durch ein firmeneigenes Logo oder Texteinträge ersetzen können.

Excel – Liste – Firmen- oder Projektspezifisch

So erstellen Sie Listen mit eigenem Layout:

Sie benötigen eine gültige Lizenz für Microsoft Excel ab Version 2000. Des Weiteren Kenntnisse im Umgang mit dem Windows Explorer und dem Texteditor, sowie im Umgang mit Microsoft Excel. Gegebenenfalls Kenntnisse im Umgang mit der artifex-Makrosprache WPS.

  • Öffnen Sie die Datei „…\artrifex\Defaults\stabdefs.txt“ im Editor. Ersetzen Sie in Zeile 3 den Eintrag für die Makro-Datei. (Beispiel: alt = wcoexcel.wps; neu = wcoexcel_meine_Firma.wps). Speichern und schließen Sie die Datei.
  • Kopieren Sie die Datei „…artifex\Data\SBW\LST\wcoexcel.wps“ nach „……\wcoecxel_meine-Firma.wps“. Öffnen Sie die Dateikopie mit dem Windows Editor. Suchen Sie die Zeile 118 „# Excel-Sheet öffnen“. Editieren Sie die in 4. Position danach liegende Zeile “    string_cat(s1,“stab_bew“)“ ersetzen Sie den Eintrag „stab_bew“ durch „stab_bew_meine_Firma“ oder den gewünschten Namen (ohne die Endung xls) für die Excel-Vorlage. Speichern und schließen Sie die Datei.
    # Excel-Sheet öffnen
    wco_Excel(„start_excel“,““,““)
    project(s1,“DEFAULTDIR“)
    string_cat(s1,“/
    stab_bew_meine_Firma„)
    wco_Excel(„GET_WORKSHEET“,s1,“Tabelle1″).

    Kopieren Sie die Datei „…artifex\Defaults\stab_bew.xls“ nach „…..\stab_bew_meine_Firma.xls“ oder den gewünschten Dateinamen. Öffnen Sie die Vorlage und verändern Sie den Listenkopf nach Bedarf.
  • Wenn Sie Erfahrung mit der artifex-Makrosprache WPS haben, können Sie in der Makrodatei (siehe oben) weitere Anpassungen zu Aussehen und Layout vornehmen. Weiteres finden Sie im Handbuch für die Makrosprache WPS, welche zum Lieferumfang gehört.

Bewehrungsliste als ABS Datei ausgeben

Für automatisierte Biegebetriebe kann die Bewehrungsbestellung über eine ABS – Datei vorgenommen werden, welche die Standard-Biegeliste ersetzt.

Erstellen der ABS Datei
Über den Befehl „Darstellen > Stahl- Biegeliste diese Zeichnung“ gelangt man in den Dialog zur Erstellung von Biegelisten.
Nachdem die Voreinstellungen zur Stahlsorte, Bauabschnitt etc. durchgeführt sind, klickt man auf das Schaltfeld „BVBS – ASCII List“:

Im nächsten Schritt wird Speicherort und Name der ABS-Listen eingegeben.

Über das Schaltfeld kann der Pfad zum Speicherort im Dateibrowser gewählt werden.
Im oberen Bereich des Ausgabedialogs können Vorgabenamen für die Ausgabepfade zur Verfügung stehen. Diese Pfade könne vom Benutzer in einer Textdatei angelegt werden. Diese Datei ist im Verzeichnis artifex\Defaults und hat den Namen SBW_BVBS_PATH.TXT

Verschieben der Stabdarstellung bei „Stäbe zeichnen“ = 6 (I?)

Öffnen, Bearbeiten und Schließen des Einstellungsdialogs:

Öffnen: Im artifex-Menü „Stabstahl“ können Sie unter dem Punkt „Stabstahl> Einstellungen> Dialog nur Stelle bei Eisen schieben anzeigen“ eine Dialogmaske einschalten.

Dialogmaske „Schieben“.

Bearbeiten: Setzen Sie ein Häkchen im Schaltfeld „Nur Stelle bei Typ…“ um den Schiebebefehl „abhängig von Anwahl“ zu erweitern. Der Zustand (Häkchen = EIN; Kein Häkchen = AUS“) bleibt nach dem Schließen des Dialogs erhalten.

Schließen: Diesen Dialog können Sie über das Schaltfeld „Close“ im Dialog oder durch erneute Anwahl des Menüpunktes wieder ausschalten.

Wirkungsweise:

Der Dialog ermöglicht das Ein- oder Ausschalten einer bestimmten Wirkung des Schiebebefehls „Ändern> Schieben> Abhängig von Anwahl“ bei der Verlegedarstellung 6 (I? = der x-te Stab). Ist im Dialog ein Häkchen gesetzt, kann mit dieser Funktion die Lage des dargestellten Stabes innerhalb des Verlegebereichs verschoben werden. Dafür muss die Verschieberichtung parallel zur Verlegerichtung sein. Ist im Dialog kein Häkchen gesetzt, wird bei Anwahl der Stabdarstellung die gesamte Verlegung verschoben.

Wirkungsweise

Zurück Stabstahl Dialoge
Weiter Stabstahl Online Schulung
Inhaltsverzeichnis